3 Get Our Newsletter!   
* Email A Friend!          
R  Checkout! 
               
  Home Products & Services View Cart Support About Us  

 

Troubleshooting Guide for PowerPlugs: Web Templates

Please review these PowerPlugs: Web Templates FAQs to see if your question is answered on this page. If your question is not addressed here, please contact CrystalGraphics technical support.

HTML and FrontPage Related Questions:
1. Where can I find a tutorial for Microsoft FrontPage?
2. What should I do if I get a "System Exception: Access Violation" error when I try to use a template?
3. What should I do if my new website is missing the shared borders?
4. Why do I see white (or some other solid color) areas in the Preview Mode of FrontPage where there should be a table background?
5. What can I do if my page no longer resizes properly?
6. I made a new website, but some of the pages have an abnormal table with bullets on the left and text pushed all the way over to the right. How can I fix this?
7. How can I get the same font style for all paragraphs in a table?
   
Getting Started with PowerPlugs: Web Templates
1. How do I get started with Powerplugs: Web Templates?
 
Navigation Buttons/Link Bars
1. Why do my navigation buttons fail to appear; I only get text hyperlinks?
2. Why do my navigation buttons fail to show after I add a new page?
3. Why does there appear to be a gap in my vertical navigation bar?
4. Why aren't the rollover effects showing when I preview the page?
5. Why are there white areas where the navigation buttons should be when viewing the page in Preview Mode?
6. How can I change the buttons or the text in my navigation bar?
7. My navigation bars show up fine in FrontPage, but not when I upload the page to the Web. What can I do?
   
Publishing/Server Issues
1.  I used FTP to upload my site, but the navigation buttons and page banners are broken. What can I do?
2. Why does my local website look fine, but the website published to my server is missing navigation bars?
3. Why does my local website look fine, but its navigation buttons do not seem to be publishing correctly - they look corrupted, do not display, or have the wrong text on them.
4. Why does my website look fine in FrontPage, but not in a browser?
5. I used the FrontPage image editing tools to overlay text on some images, and they look corrupted after publishing.
6. Why do I get an error when I try to create a new Web page directly on the server, or when I try to publish?
 
Flash/SWiSH Related Questions
1. The PowerPlugs: Web Template uses "Flash text," and allows for customization but I can't view my changes in FrontPage or on my computer. What can I do to fix this problem?
2. What is causing my SWiSH files to not operate/display properly?
3. How do I edit the SWiSH animations files that are used in some of the PowerPlugs: Web Templates?
4. How do I edit the Flash animations files that are used in some of the PowerPlugs: Web Templates?
   
HTML and FrontPage Related Questions
1.
Where can I find a tutorial for Microsoft FrontPage?
 
Please visit this link at Microsoft's website.
Top of page
2.
What should I do if I get a "System Exception: Access Violation" error when I try to use a template?
  This is a rare error which typically occurs while editing pages within templates on machines running FrontPage 2002 (Office XP) under Windows XP.
One possible solution is to go to start (at the bottom left corner of your desktop), select run, enter regedit in the resulting dialogue and delete folder 10.0 contained within HKEY_CURRENT_USER / software/Microsoft/office.

Before you delete anything, however, please make sure that you have saved it in a different directory. CrystalGraphics, Inc. cannot be held responsible for damage done to a computer through registry edits.
Top of page
3.
What should I do if my new website is missing the shared borders?
 
There may be several reasons that this occurs. One is that the template was not programmed to automatically apply the shared border. Another possibility is that the theme was packaged with an old version of the installer, which did not correctly name the web template folders. You can easily fix this by browsing to:
C:\Program Files\Microsoft Office\Templates\1033\Webs
and adding a ".tem" extension to the template's folder name. For example, change "computer" to "computer.tem"
Top of page
4.
Why do I  see white (or some other solid color) areas in the Preview Mode of FrontPage where there should be a table background?
 
This problem may be occurring because a transparent gif was used as the table background. This is occasionally employed if there are backgrounds that stretch across several table cells. Some versions of Netscape Navigator and Composer have a bug that cause table backgrounds to tile within each cell unless the cell background is specified to be a transparent image. In FrontPage, go to File>Preview in Browser and the page should look fine.
Top of page
5.
What can I do if my page no longer resizes properly?
 
You may have inadvertently dragged a table line, which will "freeze" the table at a certain width, making it no longer resizable. Using Frontpage, the easiest way to fix this is to copy your content into another page that works properly, then select "Save As" to replace the non-resizable table/page.
Top of page
6.
I made a new website, but some of the pages have a weird table with bullets on the left and text pushed all the way over to the right. How can I fix this?
 
Sometimes FrontPage will create a bullet list in an unusual table. All you have to do is highlight the cells of the table and delete them, then insert your own bulleted list.
Top of page
7.
How can I get the same font style for all paragraphs in a table?
   The HTML for a new table will look something like:
<table>
<tr>
<td>Your text here</td>
<td>Your text here</td>
</tr>
</table>

By default, FrontPage does not put your text inside of "paragraph tags," so styles are not applied to the first text that you put into a table cell. To fix this issue, insert the <p> and </p> tag around your first paragraph in HTML view so that it looks something like:
<table>
<tr>
<td><p>Your text here</p></td>
<td><p>Your text here</p></td>
</tr>
</table>
Top of page
 
Getting Started with PowerPlugs: Web Templates
1. How do I get started with Powerplugs: Web Templates?
 
Follow the instructions below to create a new website using PowerPlugs: Web Templates.

FrontPage 2000

a. Start FrontPage.
b. In the File menu, choose New and then Page or Web.
c. Select General tab and then select the template you wish to use.
d. Click OK.

FrontPage 2002
a. Start FrontPage
b. In the File menu, choose New > Page or Web.
c. On the right side you will see New Page or Web pane. In New Page or Web pane select Page templates... or website templates under New from Template section. You will see the Templates dialog.
d. Select General tab and then select the template you wish to use.
e. Click OK.

FrontPage 2003
a. Start FrontPage.
b. In the File menu, choose New.
c. On the right side you will see New pane. In New Pane select More Page templates... or More website templates. You will see Templates dialog.
e. Select General tab and then select the template you wish to use.5. Click OK.

Top of page
 
Navigation Buttons/Link Bars
1.
Why do my navigation buttons fail to appear; I only get text hyperlinks?
 
You may need to apply the theme. In FrontPage, go to Format>Theme and it will probably have "No Theme" selected. Select the desired theme.
Top of page
2.
Why do my navigation buttons fail to show after I add a new page?
 
You will need to add your new page to the navigation structure. In FrontPage, go to Navigation View, and drag your page from the folder list into the navigation structure. Also, you may need to edit the nav/link bar properties to reflect the correct level of pages that you are trying to link to.
Top of page
3.
Why does there appear to be a gap in my vertical navigation bar?
 
It's possible that there is some space between the vertical navigation and a table cell. In FrontPage, click on the vertical bar, then go to HTML view. You should see the HTML code for the vertical bar highlighted. It will look something like:
<!--webbot .... >
After that line, you will probably see something like:
</TD>
Delete the extra spaces between the two lines so that you have something like:
<!--webbot .... ></TD>
Top of page
4.
Why aren't the rollover effects showing when I preview the page?
 
If you are in Preview mode of FrontPage, this is normal. Preview mode does not show rollover effects. If you go to File>Preview In Browser and view your page in a normal browser, the rollover effects should work. Otherwise, go to Format>Theme and make sure that the "Active Graphics" box is checked.
Top of page
5.
Why are there white areas where the navigation buttons should be when viewing the page in Preview Mode?
 
This is probably because a transparent gif was used as a button image. In FrontPage, go to File>Preview>In Browser and view your page in a normal browser. Your page will probably look fine.
Top of page
6.
How can I change the buttons or the text in my navigation bar?
 
The navigation/link bars are generated by Microsoft FrontPage. In FrontPage 2000, the navigation bars are generated based on your navigation structure. You may change the text on a button by changing the Page Title in navigation view. In FrontPage 2002, you may create custom link bars. You may also choose the style of the buttons -- you may use the page's theme, or a different theme, or text styles.
Top of page
7.
My navigation bars show up fine in FrontPage, but not when I upload the page to the Web. What can I do?
 
Please consult the Publishing/Server issues section of this FAQs page.
Top of page
Publishing/Server Issues

If your website looks fine in FrontPage, but either acts differently or has some components that don't work on the server, then you maybe experiencing server issues. Written below are a list of common issues.

I use FTP to upload my site, but the navigation buttons and page banners are broken. This is an FTP issue.

My local website looks fine, but the website published to the server is missing navigation bars or the theme doesn't seem to be applying correctly.

My local website looks fine, but navigation buttons do not seem to be publishing correctly - they look corrupted, do not display, or have the wrong text on them.

My local website looks fine in FrontPage, but not when I view it in a browser.

My buttons and/or page banners on my server have black boxes instead of text.

I used the FrontPage image editing tools to overlay text on some images, and they look corrupted after publishing.

When I try to create a new Web page directly on the server, or when I try to publish, I get an error.

If you are experiencing any publishing or server issues, please follow this general troubleshooting guide below.

Get a local website (a website on your computer) to look the way you want it to, making sure that navigation bars, etc., are working properly. From that point, publish it to your server. If your website on the server is having issues, then you'll know that it's a problem with the server.

Once you confirm that the problem you are experiencing involves the server, you will need to contact your ISP. In most cases, having them reapply the FrontPage extensions to your website and republishing your website (being sure to replace all files) will fix it. (Note: The extensions are applied separately to each domain. Even if you have a different website on the same server that works fine, it's possible that you need to reapply the extensions on the website that has problems.)

If you are getting an error when you try to publish or create a new Web page directly on the server, you may be running into "permissions" problems. Contact your ISP and make sure that you have access to the necessary folders. For example, if you're getting an error that you "cannot create file ... myweb\_vti_pvt\page.cnf", make sure that you have permissions for the _vti_pvt folder.

Some FrontPage server issues can be a little trickier. Occasionally you may have to ask your ISP to completely delete everything from your folder on the server, then try republishing. This often happens if you are having problems with navigation bar images being corrupted or images that you've overlaid with text being corrupted. Sometimes you may need to open your website live off the server and recalculate your links; sometimes you may need to open your website live off the server and apply a different Theme, then reapply your Theme, or delete your home page from the navigation structure and then rebuild your navigation structure, in order to force FrontPage to recreate all the links and graphics.

FTP Issues

If you are using an FTP program to upload your site, you may experience a problem where your site is missing the images for the navigation buttons and page banners. This is because the images for the buttons and banners are in "hidden" folders in FrontPage. Because they were hidden, you probably did not upload the files.

Wherever possible, use Microsoft FrontPage's Publish feature. This will guarantee that you do not have these FTP issues. FrontPage does have a built-in "FTP" if your server does not have FrontPage extensions.

If you must use an outside FTP program, you will need to make sure that you transfer the files that are in the hidden folders as well. To see these hidden folders in FrontPage, go to Tools > Web Settings. Click the Advanced Tab and check the "show hidden files and folders" box. To see these hidden folders in Windows Explorer, go to Tools > Folder Options. Click the Views tab and select the "show hidden files and folders" option. You will then be able to view some folders like "_themes," "_fpclass," and "_derived." These folders contain the files that you need for your website to display correctly.
Top of page
Flash/SWiSH Related Questions
1.
My PowerPlugs: Web Template uses "Flash text," and allows for customization but I can't view my changes in FrontPage or on my computer. What can I do to fix this problem?

Some templates come with embedded Flash movies with text that you may change in your HTML code by defining variables. However, you may notice that even after following the instructions, the Flash text does not change (or perhaps you see "default" placeholder text like "your text here"), in FrontPage's Normal View or when you Preview in Browser.

This is most likely a Flash 6 Player issue. To test this, publish your website to a temporary place on your server. (Publish to http://yoursite.com/test instead of http://yoursite.com.) Now, view your website off of your Web server. If your text shows up fine there, then follow the instructions below to fix your code so that you can also view it on your computer.

You can easily fix this by inserting some extra lines of code in the HTML. If you open your Web page, click on the Flash movie, then go into HTML view, you'll see code that may look something like this:

[figure 1]*
<OBJECT CLASSID="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" CODEBASE="http://download.macromedia.com/..." WIDTH="400" HEIGHT="75">
<PARAM NAME="movie" VALUE="blue.swf?text1=Heading here&text2=Your text here">
<PARAM NAME="quality" VALUE="high">
<PARAM NAME="bgcolor" VALUE="#FFFFFF">
<EMBED SRC="blue.swf?text1=Heading%20here&text2=Your%20text%20here" QUALITY="high" BGCOLOR="#FFFFFF" WIDTH="400" HEIGHT="75" TYPE="application/x-shockwave-flash" PLUGINSPAGE="http://www.macromedia.com/shockwave/download...">
</EMBED>

As you may already know, the italicized text is how you define the Flash text.

To fix this issue, you will want to insert a "FlashVars" parameter in two places:

[figure 2]
<OBJECT CLASSID="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" CODEBASE="http://download.macromedia.com/..." WIDTH="400" HEIGHT="75">
<PARAM NAME="movie" VALUE="blue.swf?text1=Heading here&text2=Your text here">
<PARAM NAME="FlashVars" VALUE="text1=Heading here&text2=Your text here">
<PARAM NAME="quality" VALUE="high">
<PARAM NAME="bgcolor" VALUE="#FFFFFF">
<EMBED SRC="blue.swf?text1=Heading%20here&text2=Your%20text%20here"
FLASHVARS="text1=Heading%20here&text2=Your%20text%20here" QUALITY="high" BGCOLOR="#FFFFFF" WIDTH="400" HEIGHT="75" TYPE="application/x-shockwave-flash" PLUGINSPAGE="http://www.macromedia.com/shockwave/download...">
</EMBED>

First, you will need to insert another "<PARAM...>" tag with the FlashVars statement. For the "VALUE," simply use the original variables in the first PARAM statement (just copy and paste!). Second, you will need to insert a "FLASHVARS" statement inside the <EMBED ...> tag. Once again, use the same variables as in the "SRC" part before it.

*Some templates may only have the <EMBED> tag and not all the <OBJECT...> and <PARAM> tags. In this case, only put the FLASHVARS="text1=Heading%20here&text2=Your%20text%20here" statement inside the EMBED tag.
Top of page
2.
What is causing my SWiSH files to not operate/display properly?
 
Make sure you are exporting display files to your FrontPage website as .swf files and not .swi files, otherwise your Web browser won't be able to read them.
Top of page
3.
How do I edit the SWiSH animation files that are used in some of the PowerPlugs: Web Templates?
 
While SWiSH animation is included in some of the PowerPlugs: Web Templates, the product that creates this animation is not. It is produced by SWiSHzone.com Pty Ltd and you will need to download the product (SWiSH) from www.SWiSHzone.com to edit your SWiSH files.
Top of page
4.
How do I edit the Flash animations files that are used in some of the PowerPlugs: Web Templates?
 
Go to www.macromedia.com and download the latest version of Flash by Macromedia, Inc. Extensive information on how to use the product is also available at their site.
Top of page

If your questions are not addressed here, please contact technical support.

 

    
    © CrystalGraphics, Inc. All rights Reserved. Privacy Policy by TRUSTe
Microsoft and the Office logo are trademarks or registered trademarks of Microsoft Corporation in the United States and/or other countries.

-